80.3 自定义依赖版本

如果你使用Maven进行一个直接或间接继承spring-boot-dependencies(比如spring-boot-starter-parent)的构建,并想覆盖一个特定的第三方依赖,那你可以添加合适的<properties>元素。浏览spring-boot-dependencies POM可以获取一个全面的属性列表。例如,想要选择一个不同的slf4j版本,你可以添加以下内容:

<properties>
    <slf4j.version>1.7.5<slf4j.version>
</properties>

这只在你的Maven项目继承(直接或间接)自spring-boot-dependencies才有用。如果你使用<scope>import</scope>,将spring-boot-dependencies添加到自己的dependencyManagement片段,那你必须自己重新定义artifact而不是覆盖属性。

每个Spring Boot发布都是基于一些特定的第三方依赖集进行设计和测试的,覆盖版本可能导致兼容性问题。

Gradle中为了覆盖依赖版本,你需要指定如下所示的version:

ext['slf4j.version'] = '1.7.5'

更多详情查看Gradle Dependency Management插件文档

results matching ""

    No results matching ""